TecnoInFe: Tecnología, Informática y Educación

domingo, 8 de julio de 2018

Cálculo de la letra del Nif con CALC

En un ejercicio realizado en clase, veíamos como calcular la letra del NIF:


Aclaración 1: Me preguntabais en clase, como hacer para que cuando no hayamos introducido ningún DIN, la letra apareciera en blanco, puesto que por defecto  el programa interpretaba que se trataba de un DIN de 0 y me calculaba la letra.

Es tan sencillo como en el resultado poner un condicional: SI(S13=0;" "; BUSCARH......))
 S13 es la celda donde sala el resultado del cálculo.

Aclaración 2: La forma de calcular la letra anterior está muy bien de cara a entender, como se calcula dicha letra, pero para incorporarlo a una hoja más compleja no sería viable. Existe una forma directa de realizar el cálculo, con la siguiente fórmula:

=SI(AA8="";"NADA";MID("TRWAGMYFPDXBNJZSQVHLCKE";1+RESIDUO(AA8;23);1))

Teniendo en cuenta la fórmula anterior, podríamos realizar una estructura como esta:


La unión de los resultados de dos celdas como puedes ver en la celda AC8, se hace nombrando las dos celdas a unir y usando entre ellas el símbolo &: AA8&" - " &Si......

Aclaración 3: ¿Cómo calcularíamos la letra si se tratara de un NIE? es decir, un DNI extranjero

Estudiando un poco lo que nos explica la web del Ministerio del Interior sobre el cálculo del NIE, podemos ver que existen tres tipos de NIE, que pueden empezar por X, Y o Z, asignando los valores 0, 1, y 2 respectivamente y el resto serían 7 número.

Por tanto, teniendo eso claro, podríamos crear una hoja tal que así:


O bien, ponemos nosotros la letra o creamos un rango de valores permitidos. El DNI de cálculo o DNI Completo, serían creando un condicional teniendo en cuenta si la celda en cuestión es X, sería igual a 0, Y igual a 1.... Por ejemplo:

=SI(A11="X";0&B3;SI(A11="Y";1&B3;SI(A11="Z";2&B3)))




No hay comentarios:

Publicar un comentario